summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2020-08-20 17:35:50 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2020-08-26 14:35:32 +0200
commitef913253494f28fb0708fb072415fb59a1924491 (patch)
tree75a57abc311c42557dc31382d5a5e7b54817823a /meson.build
parent83f7c0a7ec79fdc6dc27ee94743189b769ab2500 (diff)
downloadsystemd-ef913253494f28fb0708fb072415fb59a1924491.tar.gz
meson: add ENABLE_ANALYZE conditional
(cherry picked from commit b3259a6e5f05ebaf5282e624f80ecf04b77a0adb)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build57
1 files changed, 29 insertions, 28 deletions
diff --git a/meson.build b/meson.build
index 56cf31f757..ba9e7afe53 100644
--- a/meson.build
+++ b/meson.build
@@ -1415,42 +1415,43 @@ else
endif
conf.set10('ENABLE_REMOTE', have)
-foreach term : ['utmp',
- 'hibernate',
- 'environment-d',
+foreach term : ['analyze',
+ 'backlight',
'binfmt',
'coredump',
- 'pstore',
- 'resolve',
- 'logind',
+ 'efi',
+ 'environment-d',
+ 'firstboot',
+ 'gshadow',
+ 'hibernate',
'hostnamed',
+ 'hwdb',
+ 'idn',
+ 'ima',
+ 'initrd',
+ 'ldconfig',
'localed',
+ 'logind',
'machined',
- 'portabled',
- 'userdb',
'networkd',
- 'timedated',
- 'timesyncd',
- 'firstboot',
- 'randomseed',
- 'backlight',
- 'vconsole',
+ 'nss-myhostname',
+ 'nss-systemd',
+ 'portabled',
+ 'pstore',
'quotacheck',
+ 'randomseed',
+ 'resolve',
+ 'rfkill',
+ 'smack',
'sysusers',
+ 'timedated',
+ 'timesyncd',
'tmpfiles',
- 'hwdb',
- 'rfkill',
- 'xdg-autostart',
- 'ldconfig',
- 'efi',
'tpm',
- 'ima',
- 'smack',
- 'gshadow',
- 'idn',
- 'initrd',
- 'nss-myhostname',
- 'nss-systemd']
+ 'userdb',
+ 'utmp',
+ 'vconsole',
+ 'xdg-autostart']
have = get_option(term)
name = 'ENABLE_' + term.underscorify().to_upper()
conf.set10(name, have)
@@ -1767,7 +1768,7 @@ public_programs += executable(
libmount,
libblkid],
install_rpath : rootlibexecdir,
- install : get_option('analyze'))
+ install : conf.get('ENABLE_ANALYZE'))
executable(
'systemd-journald',
@@ -3683,7 +3684,7 @@ foreach tuple : [
['link-networkd-shared', get_option('link-networkd-shared')],
['link-timesyncd-shared', get_option('link-timesyncd-shared')],
['kernel-install', get_option('kernel-install')],
- ['systemd-analyze', get_option('analyze')],
+ ['systemd-analyze', conf.get('ENABLE_ANALYZE') == 1],
]
if tuple.length() >= 2