summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-24 19:28:04 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-24 19:28:04 -0400
commit5464ec8a8e7a84341d192e7614ad55c159652751 (patch)
tree0d49d99f7165766f85c0c1443d7fdb1ce6743e68 /meson.build
parent80c6fce81cd1256cbc65bf567aaaa42b6cd60691 (diff)
downloadsystemd-5464ec8a8e7a84341d192e7614ad55c159652751.tar.gz
meson: there is no smack library
Detection would always fail, so this was broken. Treat this as a binary enable/disable option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 1 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index ae577660cd..59318a9a5d 100644
--- a/meson.build
+++ b/meson.build
@@ -642,18 +642,6 @@ else
libapparmor = []
endif
-want_smack = get_option('smack')
-if want_smack != 'false'
- libsmack = dependency('libsmack',
- required : want_smack == 'true')
- if libsmack.found()
- conf.set('HAVE_SMACK', 1)
- m4_defines += ['-DHAVE_SMACK']
- endif
-else
- libsmack = []
-endif
-
smack_run_label = get_option('smack-run-label')
if smack_run_label != ''
conf.set_quoted('SMACK_RUN_LABEL', smack_run_label)
@@ -988,6 +976,7 @@ foreach pair : [['utmp', 'HAVE_UTMP'],
['efi', 'ENABLE_EFI'],
['tpm', 'SD_BOOT_LOG_TPM'],
['ima', 'HAVE_IMA'],
+ ['smack', 'HAVE_SMACK'],
]
if get_option(pair[0])