summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-19 22:57:52 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-24 19:24:36 -0400
commit6800fe7f0678c2a3875005bdef147e10eac67428 (patch)
treeede35e6acaebd24f356e7373845370ac4e24a572 /meson.build
parent4984c8be739dffe4cf9ff3ab905eb3b2ee3ca826 (diff)
downloadsystemd-6800fe7f0678c2a3875005bdef147e10eac67428.tar.gz
meson: define gnu_efi_arch for the arch efi name, fix ldsdir detection
This fixes ldsdir detection under Debian. v2: - define gnu_efi_arch for the arch efi include directory name In the autotools naming convention, efi_arch and this directory always had the same name. But meson.cpu_family() uses a slightly different convention, so those two don't always match.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index df08545159..97fff496e1 100644
--- a/meson.build
+++ b/meson.build
@@ -977,16 +977,21 @@ tests = []
if get_option('efi')
efi_arch = host_machine.cpu_family()
- if efi_arch == 'ia32'
+ if efi_arch == 'x86'
EFI_MACHINE_TYPE_NAME = 'ia32'
+ gnu_efi_arch = 'ia32'
elif efi_arch == 'x86_64'
EFI_MACHINE_TYPE_NAME = 'x64'
+ gnu_efi_arch = 'x86_64'
elif efi_arch == 'arm'
EFI_MACHINE_TYPE_NAME = 'arm'
+ gnu_efi_arch = 'arm'
elif efi_arch == 'aarch64'
EFI_MACHINE_TYPE_NAME = 'aa64'
+ gnu_efi_arch = 'aarch64'
else
EFI_MACHINE_TYPE_NAME = ''
+ gnu_efi_arch = ''
endif
conf.set('ENABLE_EFI', 1)