summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2019-10-25 16:06:06 +0200
committerLennart Poettering <lennart@poettering.net>2019-12-04 10:33:41 +0100
commit5f152f43d04e5aad6a3f98f45f020a66e3aac717 (patch)
treeda4cd9525b3a570fa21e4725a438bb30f6bf8988 /meson.build
parent5a795bff38402d1a7e82020888eb1da5d52ad4a7 (diff)
downloadsystemd-5f152f43d04e5aad6a3f98f45f020a66e3aac717.tar.gz
missing: define new pidfd syscalls
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 21d6968abd..edde42ea74 100644
--- a/meson.build
+++ b/meson.build
@@ -517,6 +517,14 @@ foreach ident : [
#include <unistd.h>'''],
['get_mempolicy', '''#include <stdlib.h>
#include <unistd.h>'''],
+ ['pidfd_send_signal', '''#include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <sys/wait.h>'''],
+ ['pidfd_open', '''#include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <sys/wait.h>'''],
]
have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')