summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 20:54:46 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-01-03 12:09:46 +0100
commit0c06b50662b94c6805c78193ac4d80875ae33668 (patch)
tree5b335ea2f5a558c8f10836b441527ee5514c5291 /meson.build
parent5e3cec87bee762c4429ec1251632d58e5fd029bd (diff)
downloadsystemd-0c06b50662b94c6805c78193ac4d80875ae33668.tar.gz
meson: rename libudev_internal to libudev_static and link into libudev
This reduces the meson man=false target count to 1281. v2: - link test-engine with libshared instead of libsystemd_static Previous version built fine on F27, but fails on F26 with the following error: /usr/bin/ld: /tmp/ccr8HRGw.ltrans6.ltrans.o: undefined reference to symbol '__start_BUS_ERROR_MAP@@SD_SHARED' /home/zbyszek/fedora/systemd/systemd-9d5aae75c64f5583a110f03b94816aacc03bbf4d/x86_64-redhat-linux-gnu/src/shared/libsystemd-shared-236.so: error adding symbols: DSO missing from command line v3: - add libudev_basic
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 3e5242e09e..e73b24dedb 100644
--- a/meson.build
+++ b/meson.build
@@ -2223,7 +2223,7 @@ if conf.get('ENABLE_HWDB') == 1
'src/hwdb/hwdb.c',
'src/libsystemd/sd-hwdb/hwdb-internal.h',
include_directories : includes,
- link_with : [libudev_internal],
+ link_with : [libudev_static],
install_rpath : udev_rpath,
install : true,
install_dir : rootbindir)
@@ -2256,7 +2256,7 @@ exe = executable('systemd-udevd',
c_args : ['-DLOG_REALM=LOG_REALM_UDEV'],
link_with : [libudev_core,
libsystemd_network,
- libudev_internal],
+ libudev_static],
dependencies : [threads,
libkmod,
libidn,
@@ -2273,7 +2273,7 @@ exe = executable('udevadm',
include_directories : includes,
link_with : [libudev_core,
libsystemd_network,
- libudev_internal],
+ libudev_static],
dependencies : [threads,
libkmod,
libidn,
@@ -2347,7 +2347,7 @@ if conf.get('ENABLE_NETWORKD') == 1
include_directories : includes,
link_with : [libnetworkd_core,
libsystemd_network,
- libudev_internal,
+ libudev_static,
libshared],
dependencies : [threads],
install_rpath : rootlibexecdir,