summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2017-11-26 12:35:07 +0900
committerGitHub <noreply@github.com>2017-11-26 12:35:07 +0900
commitdd5082a9de2405c3bb4b4964c4929918baa9c695 (patch)
tree34289715a435692cfe9e28fdd246ec1a248a3024 /meson.build
parent07920ba095501f66fcd1c497d38c81d52666f714 (diff)
parent7accca234dc413f058082c54bc3fa065b75142e9 (diff)
downloadsystemd-dd5082a9de2405c3bb4b4964c4929918baa9c695.tar.gz
Merge pull request #7468 from yuwata/fix-7362
test and meson cleanups
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6926880b29..6ca506c41f 100644
--- a/meson.build
+++ b/meson.build
@@ -442,7 +442,8 @@ foreach ident : ['secure_getenv', '__secure_getenv']
endforeach
foreach ident : [
- ['memfd_create', '''#include <sys/memfd.h>'''],
+ ['memfd_create', '''#define _GNU_SOURCE
+ #include <sys/mman.h>'''],
['gettid', '''#include <sys/types.h>'''],
['pivot_root', '''#include <stdlib.h>'''], # no known header declares pivot_root
['name_to_handle_at', '''#define _GNU_SOURCE