summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNorbert Lange <nolange79@gmail.com>2020-04-28 23:11:55 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2020-05-26 15:04:36 +0200
commit6589a56972d9afe9d860889f11cb9c8e6cb8a60c (patch)
tree617065f38a70bcf4333e95caa1f807a05adc4f97 /meson.build
parenta53a85b35e9f763a508a449b9390f898a1268f90 (diff)
downloadsystemd-6589a56972d9afe9d860889f11cb9c8e6cb8a60c.tar.gz
dont install systemd-initctl, runlevel, telinit if no SYSV compat
systemd-initctl executable is still built.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b87d5c63a3..53c450eb01 100644
--- a/meson.build
+++ b/meson.build
@@ -2189,7 +2189,8 @@ if conf.get('ENABLE_HOMED') == 1
endif
endif
-foreach alias : ['halt', 'poweroff', 'reboot', 'runlevel', 'shutdown', 'telinit']
+foreach alias : (['halt', 'poweroff', 'reboot', 'shutdown'] +
+ (conf.get('HAVE_SYSV_COMPAT') == 1 ? ['runlevel', 'telinit'] : []))
meson.add_install_script(meson_make_symlink,
join_paths(rootbindir, 'systemctl'),
join_paths(rootsbindir, alias))
@@ -2851,7 +2852,7 @@ executable(
include_directories : includes,
link_with : [libshared],
install_rpath : rootlibexecdir,
- install : true,
+ install : (conf.get('HAVE_SYSV_COMPAT') == 1),
install_dir : rootlibexecdir)
public_programs += executable(