summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2021-01-04 20:43:44 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-01-19 07:06:32 +0900
commit73e994f291c45442969b75671bd0fba2656102ab (patch)
treee2c0783418755ed5732bd21b77e78fc3af4c8607 /meson.build
parent0275e918afd184d297c3da4f6f64ad16f7dead71 (diff)
downloadsystemd-73e994f291c45442969b75671bd0fba2656102ab.tar.gz
meson: drop redundant source files in executable()
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 7396c943c0..70dc7bd104 100644
--- a/meson.build
+++ b/meson.build
@@ -1965,7 +1965,6 @@ if conf.get('HAVE_BLKID') == 1
executable(
'systemd-gpt-auto-generator',
'src/gpt-auto-generator/gpt-auto-generator.c',
- 'src/shared/blkid-util.h',
include_directories : includes,
link_with : [libshared],
dependencies : libblkid,
@@ -3102,7 +3101,6 @@ if conf.get('ENABLE_HWDB') == 1
public_programs += executable(
'systemd-hwdb',
'src/hwdb/hwdb.c',
- 'src/libsystemd/sd-hwdb/hwdb-internal.h',
include_directories : includes,
link_with : udev_link_with,
install_rpath : udev_rpath,
@@ -3258,7 +3256,7 @@ endif
executable(
'systemd-sulogin-shell',
- ['src/sulogin-shell/sulogin-shell.c'],
+ 'src/sulogin-shell/sulogin-shell.c',
include_directories : includes,
link_with : [libshared],
install_rpath : rootlibexecdir,