summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-07-02 13:01:23 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-07-10 14:59:48 +0200
commit91b08bb00fb9b7e1de223709f4564b8fcedc711b (patch)
treed7436c669e442b7a14bd965eb38e0a677781140e /meson.build
parente04df06f5876ec4f3b068bccc5fa4a53ab6bf9b2 (diff)
downloadsystemd-91b08bb00fb9b7e1de223709f4564b8fcedc711b.tar.gz
boot,shared: share the definitions of EFI_LOADER_FEATURE macros
This means the the code needs to be kept compatible in the shared header, but I think that still nicer than having two places to declare the same things. I added src/boot to -I, so that efi/foo.h needs to be used. This reduces the potential for accidentally including the wrong header.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3a936947bb..4d40451fa6 100644
--- a/meson.build
+++ b/meson.build
@@ -1368,6 +1368,7 @@ config_h = configure_file(
meson_apply_m4 = find_program('tools/meson-apply-m4.sh')
includes = include_directories('src/basic',
+ 'src/boot',
'src/shared',
'src/systemd',
'src/journal',