summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-03-09 14:21:08 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-03-09 14:21:08 +0100
commitaf4d7860c4e757f34a02ca73a0b14c73c18f8b30 (patch)
tree612e59f65e7de050ce6f502994361034325fb8d0 /meson.build
parentf83f8c70bd518e2b7a0011d82a2fb7074fb3a19a (diff)
downloadsystemd-af4d7860c4e757f34a02ca73a0b14c73c18f8b30.tar.gz
meson: avoid warning about comparison of bool and string
meson.build:2907: WARNING: Trying to compare values of different types (bool, str) using ==. The result of this is undefined and will become a hard error in a future Meson release.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 30b7f1bafa..e152226ead 100644
--- a/meson.build
+++ b/meson.build
@@ -2903,8 +2903,9 @@ foreach tuple : [
['debug mmap cache'],
]
- cond = tuple.get(1, '')
- if cond == ''
+ if tuple.length() >= 2
+ cond = tuple[1]
+ else
ident1 = 'HAVE_' + tuple[0].underscorify().to_upper()
ident2 = 'ENABLE_' + tuple[0].underscorify().to_upper()
cond = conf.get(ident1, 0) == 1 or conf.get(ident2, 0) == 1