summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-04-14 15:54:52 +0200
committerLennart Poettering <lennart@poettering.net>2020-07-01 11:17:28 +0200
commitaf4fbd463fa9c0f37a91a8f7b380655c6dcdba3f (patch)
tree5f002162e8f56efeef66ec2e210abb2be366047a /meson.build
parentc0bde0d2402b203207d1ec2f998e661ee0fe177c (diff)
downloadsystemd-af4fbd463fa9c0f37a91a8f7b380655c6dcdba3f.tar.gz
build-sys: add libfido2 as optional dependency
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 08f322117f..e2ccb658c8 100644
--- a/meson.build
+++ b/meson.build
@@ -1153,6 +1153,17 @@ else
endif
conf.set10('HAVE_P11KIT', have)
+want_libfido2 = get_option('libfido2')
+if want_libfido2 != 'false' and not skip_deps
+ libfido2 = dependency('libfido2',
+ required : want_libfido2 == 'true')
+ have = libfido2.found()
+else
+ have = false
+ libfido2 = []
+endif
+conf.set10('HAVE_LIBFIDO2', have)
+
want_elfutils = get_option('elfutils')
if want_elfutils != 'false' and not skip_deps
libdw = dependency('libdw',
@@ -3575,6 +3586,7 @@ foreach tuple : [
['pwquality'],
['libfdisk'],
['p11kit'],
+ ['libfido2'],
['AUDIT'],
['IMA'],
['AppArmor'],