summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@microsoft.com>2021-05-19 14:45:47 +0100
committerLennart Poettering <lennart@poettering.net>2021-05-19 23:25:34 +0200
commit2d4efd1dba568e59b149fbb82b51201951e8e178 (patch)
tree6d51d8e3f829c9aee3ddd48028d285ee1b2b1913 /meson.build
parent2adcf6f4f7d1f74b02553d7128f73fcd2886fa55 (diff)
downloadsystemd-2d4efd1dba568e59b149fbb82b51201951e8e178.tar.gz
build tests: check that Github pages can be built successfully
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8b1871523f..2111d83870 100644
--- a/meson.build
+++ b/meson.build
@@ -3501,6 +3501,21 @@ meson.add_install_script('sh', '-c', 'touch $DESTDIR@0@'.format(prefixdir))
############################################################
+# Ensure that changes to the docs/ directory do not break the
+# basic Github pages build. But only run it in developer mode,
+# as it might be fragile due to changes in the tooling, and it is
+# not generally useful for users.
+jekyll = find_program('jekyll', required : false)
+if get_option('mode') == 'developer' and want_tests != 'false' and jekyll.found()
+ test('github-pages',
+ jekyll,
+ args : ['build',
+ '--source', join_paths(project_source_root, 'docs'),
+ '--destination', join_paths(project_build_root, '_site')])
+endif
+
+############################################################
+
check_help = find_program('tools/check-help.sh')
foreach exec : public_programs