summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Hilliard <james.hilliard1@gmail.com>2018-12-27 09:16:20 +0800
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-12-28 12:17:06 +0900
commit46e63a2a3ed46ce97430ce38e4cc0798c57900eb (patch)
tree92e2d546c281fcb4694bad7ae7ac876251486529 /meson.build
parent8eab766804ef4fa21d26c00fd0baab3f1a47bb5c (diff)
downloadsystemd-46e63a2a3ed46ce97430ce38e4cc0798c57900eb.tar.gz
meson: use cross compilation compatible c++ check
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index b338886c38..1964b1aa87 100644
--- a/meson.build
+++ b/meson.build
@@ -287,10 +287,8 @@ want_tests = get_option('tests')
slow_tests = want_tests != 'false' and get_option('slow-tests')
install_tests = get_option('install-tests')
-cxx = find_program('c++', required : fuzzer_build)
-if cxx.found()
+if add_languages('cpp', required : fuzzer_build)
# Used only for tests
- add_languages('cpp')
cxx_cmd = ' '.join(meson.get_compiler('cpp').cmd_array())
else
cxx_cmd = ''