summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2021-04-27 14:16:06 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-04-28 15:41:34 +0200
commit84e8edec308dd157a013c811c3fa351fc0340f63 (patch)
tree50f25d856de7b8b92f3426338155780e9c296049 /meson.build
parent9899580a586522330bdb657bf228402638b6dbc2 (diff)
downloadsystemd-84e8edec308dd157a013c811c3fa351fc0340f63.tar.gz
missing: add syscall wrappers for new mount API
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 93d3c26a22..f30b7eef79 100644
--- a/meson.build
+++ b/meson.build
@@ -480,11 +480,14 @@ conf.set('SIZEOF_RLIM_T', cc.sizeof('rlim_t', prefix : '#include <sys/resource.h
decl_headers = '''
#include <uchar.h>
+#include <sys/mount.h>
#include <sys/stat.h>
+#include <linux/fs.h>
'''
foreach decl : ['char16_t',
'char32_t',
+ 'struct mount_attr',
'struct statx',
]
@@ -555,6 +558,9 @@ foreach ident : [
['execveat', '''#include <unistd.h>'''],
['close_range', '''#include <unistd.h>'''],
['epoll_pwait2', '''#include <sys/epoll.h>'''],
+ ['mount_setattr', '''#include <sys/mount.h>'''],
+ ['move_mount', '''#include <sys/mount.h>'''],
+ ['open_tree', '''#include <sys/mount.h>'''],
]
have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')