summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-11-23 00:36:35 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-11-23 00:36:35 +0900
commitd6601495beea0044dc9bf72ca2cd92e3963a30d4 (patch)
tree27bec90a905879c48401dcb79452e61e1824431d /meson.build
parent20e97dd3decbf8fe9127e41787af5420062deec0 (diff)
downloadsystemd-d6601495beea0044dc9bf72ca2cd92e3963a30d4.tar.gz
meson: also add option for debugging siphash
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c746776208..5dc25d03dc 100644
--- a/meson.build
+++ b/meson.build
@@ -782,12 +782,15 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
enable_debug_hashmap = false
enable_debug_mmap_cache = false
+enable_debug_siphash = false
enable_debug_udev = false
foreach name : get_option('debug-extra')
if name == 'hashmap'
enable_debug_hashmap = true
elif name == 'mmap-cache'
enable_debug_mmap_cache = true
+ elif name == 'siphash'
+ enable_debug_siphash = true
elif name == 'udev'
enable_debug_udev = true
else
@@ -796,6 +799,7 @@ foreach name : get_option('debug-extra')
endforeach
conf.set10('ENABLE_DEBUG_HASHMAP', enable_debug_hashmap)
conf.set10('ENABLE_DEBUG_MMAP_CACHE', enable_debug_mmap_cache)
+conf.set10('ENABLE_DEBUG_SIPHASH', enable_debug_siphash)
conf.set10('ENABLE_DEBUG_UDEV', enable_debug_udev)
conf.set10('VALGRIND', get_option('valgrind'))
@@ -3132,6 +3136,7 @@ foreach tuple : [
['gshadow'],
['debug hashmap'],
['debug mmap cache'],
+ ['debug siphash'],
['debug udev'],
['valgrind', conf.get('VALGRIND') == 1],
['trace logging', conf.get('LOG_TRACE') == 1],