summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-04-15 08:20:31 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-04-28 11:32:58 +0200
commitecd1bfdd3cea0a11c4ba1a6a7dbc86d868349877 (patch)
treee40fa1c349a1d66bba1f9c8ec5042287774a8a62 /meson.build
parentfe12f036fe7f10044bd9adc9a5817f796fa07f17 (diff)
downloadsystemd-ecd1bfdd3cea0a11c4ba1a6a7dbc86d868349877.tar.gz
hwdb-test: pass an explit path to systemd-hwdb
https://github.com/systemd/systemd/pull/19316 failed with: [1065/1670] Linking target systemd-hwdb --- command --- 14:28:29 /root/src/test/hwdb-test.sh --- stdout --- ./systemd-hwdb does not exist, please build first I'm not sure what is going on here… In principle meson says that tests may be called from any directory, but in practice is was always the build directory. So far we were relying on systemd-hwdb being present in '.', and this worked. Either way, it's nicer to pass the exact path, so let's do that.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 93d3c26a22..3d5ae16a61 100644
--- a/meson.build
+++ b/meson.build
@@ -3168,7 +3168,7 @@ if conf.get('ENABLE_TMPFILES') == 1
endif
if conf.get('ENABLE_HWDB') == 1
- public_programs += executable(
+ systemd_hwdb = executable(
'systemd-hwdb',
'src/hwdb/hwdb.c',
include_directories : includes,
@@ -3176,6 +3176,14 @@ if conf.get('ENABLE_HWDB') == 1
install_rpath : udev_rpath,
install : true,
install_dir : rootbindir)
+ public_programs += systemd_hwdb
+
+ if want_tests != 'false'
+ test('hwdb-test',
+ hwdb_test_sh,
+ args : [systemd_hwdb.full_path()],
+ timeout : 90)
+ endif
endif
if conf.get('ENABLE_QUOTACHECK') == 1