summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2021-10-08 10:46:02 +0200
committerLennart Poettering <lennart@poettering.net>2021-10-11 14:31:34 +0200
commitaab35b1e5907a7ac0a218b4f220c66e6d79eb39a (patch)
tree570f7e51dae4b7a0a9e846fde68dcc3c043df700 /meson.build
parentb1967fb83a21aedc5882c665cbccf4b55f4282be (diff)
downloadsystemd-aab35b1e5907a7ac0a218b4f220c66e6d79eb39a.tar.gz
missing: add getdents64() syscall wrapper
glibc 2.30 (Aug 2019) added a wrapper for getdents64(). For older versions let's define our own. (This syscall exists since Linux 2.4, hence should be safe to use for us)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7d97ba2fe9..6c5d4bb34c 100644
--- a/meson.build
+++ b/meson.build
@@ -546,6 +546,7 @@ foreach ident : [
['mount_setattr', '''#include <sys/mount.h>'''],
['move_mount', '''#include <sys/mount.h>'''],
['open_tree', '''#include <sys/mount.h>'''],
+ ['getdents64', '''#include <dirent.h>'''],
]
have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')