summaryrefslogtreecommitdiff
path: root/src/journal/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 19:38:43 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-01-03 12:09:46 +0100
commit5e3cec87bee762c4429ec1251632d58e5fd029bd (patch)
tree7d454350d4aa6f4db9363480b2bb65eb64227d5c /src/journal/meson.build
parenta8e559d4c66d0286061328a0ad5cbfed9080d29c (diff)
downloadsystemd-5e3cec87bee762c4429ec1251632d58e5fd029bd.tar.gz
meson: use a convenience lib for journal user sources
Instead of compiling those files twice, once for libsystemd and once for libshared, compile once as a static archive and then link into both. This reduce the meson target for man=no compile to 1291.
Diffstat (limited to 'src/journal/meson.build')
-rw-r--r--src/journal/meson.build12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/journal/meson.build b/src/journal/meson.build
index e4d78f330d..a23f6a712c 100644
--- a/src/journal/meson.build
+++ b/src/journal/meson.build
@@ -15,7 +15,7 @@
# You should have received a copy of the GNU Lesser General Public License
# along with systemd; If not, see <http://www.gnu.org/licenses/>.
-journal_internal_sources = files('''
+journal_client_sources = files('''
audit-type.c
audit-type.h
catalog.c
@@ -38,7 +38,7 @@ journal_internal_sources = files('''
'''.split())
if conf.get('HAVE_GCRYPT') == 1
- journal_internal_sources += files('''
+ journal_client_sources += files('''
journal-authenticate.c
journal-authenticate.h
fsprg.c
@@ -69,7 +69,13 @@ audit_type_to_name = custom_target(
command : [awk, '-f', '@INPUT0@', '@INPUT1@'],
capture : true)
-journal_internal_sources += [audit_type_to_name]
+journal_client_sources += [audit_type_to_name]
+
+libjournal_client = static_library(
+ 'journal-client',
+ journal_client_sources,
+ include_directories : includes,
+ c_args : ['-fvisibility=default'])
############################################################