summaryrefslogtreecommitdiff
path: root/src/kernel-install/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-03-07 21:18:56 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-03-12 09:45:16 +0100
commitcf73f650890b56a59bfb713c4c82b4e29daa7316 (patch)
tree96127f9169940270fc64f0007600342ecdaeadb2 /src/kernel-install/meson.build
parent341890de866f2ee34919a47ce3fc6c8cd3c1924c (diff)
downloadsystemd-cf73f650890b56a59bfb713c4c82b4e29daa7316.tar.gz
kernel-install: create the entry directory only if $BOOT/$MACHINE_ID exists
Things are currently fairly ugly in Fedora: we create $BOOT/$MACHINE_ID/$KERNEL_VERSION/, and then 20-grub.install that is installed by grub2-common.rpm wants to remove that directory before 50-dracut.install get a chance to run. 50-dracut.install checks for the presence of that directory to decide where to install the kernel. So let's make the creation of the directory conditional. Previous commit changes bootctl install to create $BOOT/$MACHINE_ID, and this commit makes kernel-install not create it. In effect, the entry directory will only be created if 'bootctl install' or something else created the parent directory. https://bugzilla.redhat.com/show_bug.cgi?id=1648907
Diffstat (limited to 'src/kernel-install/meson.build')
-rw-r--r--src/kernel-install/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/kernel-install/meson.build b/src/kernel-install/meson.build
index c6e6f816d9..261c3aaae4 100644
--- a/src/kernel-install/meson.build
+++ b/src/kernel-install/meson.build
@@ -4,7 +4,8 @@ install_data('kernel-install',
install_mode : 'rwxr-xr-x',
install_dir : bindir)
-install_data('50-depmod.install',
+install_data('00-entry-directory.install',
+ '50-depmod.install',
'90-loaderentry.install',
install_mode : 'rwxr-xr-x',
install_dir : kernelinstalldir)