summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-12-09 21:09:33 +0100
committerGitHub <noreply@github.com>2020-12-09 21:09:33 +0100
commit733558adef7787f1a66c301bc36c4740218d16aa (patch)
treec8256cccf67289876560df746489fa4bb08bb0a8 /src/test/meson.build
parent4e1db59274c4b31ba5369270a489420245616eb4 (diff)
parenta6c7811f0d3888e2fa545cd80d7815049b5cb084 (diff)
downloadsystemd-733558adef7787f1a66c301bc36c4740218d16aa.tar.gz
Merge pull request #17884 from poettering/test-dlopen
tests: add test that dlopen()s our weak shared library deps once
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 9e781f88dc..3afe5d58cb 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -71,6 +71,10 @@ tests += [
libshared],
[]],
+ [['src/test/test-dlopen-so.c'],
+ [libshared],
+ []],
+
[['src/test/test-job-type.c'],
[libcore,
libshared],