summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-10-12 11:45:20 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-10-12 17:54:23 +0900
commita6ee01caf3409ba9820e8824b9262fbac31a9f77 (patch)
tree6565dde8e730400c7ab7488445e6163010bc18ab /src/test/meson.build
parent657ccaac1b898e6cb4865df38d1cf09c50f6c0ac (diff)
downloadsystemd-a6ee01caf3409ba9820e8824b9262fbac31a9f77.tar.gz
test: add test for 'thread safety' of sd-device
This adds a test for a5d8835c78112206bbf0812dd4cb471f803bfe88.
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index daf5e7c76a..9ce0bdec78 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -904,6 +904,12 @@ tests += [
[['src/libsystemd/sd-device/test-sd-device.c'],
[],
[]],
+
+ [['src/libsystemd/sd-device/test-sd-device-thread.c'],
+ [libbasic,
+ libshared_static,
+ libsystemd],
+ [threads]],
]
if cxx.found()