summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-12-07 16:24:55 +0100
committerLennart Poettering <lennart@poettering.net>2018-12-15 12:10:19 +0100
commitf079c3727c9b23cb71ff862d66f8c31246ca3326 (patch)
treeed779de9512285e556b856ed37a4cdd00f348942 /src/test/meson.build
parentd3e5af0440d04b0ff559d81074fa96b99fb51746 (diff)
downloadsystemd-f079c3727c9b23cb71ff862d66f8c31246ca3326.tar.gz
shared: add helper for flushing nscd caches
Apparently, people do use nscd, hence play somewhat nice with it, and let's explicitly flush nscd caches whenever we register a new user/group. This patch only adds the actual refresh request invocation. Later commits then issue this call at appropriate moments. Note that the nscd protocol is not officially documented though very simple. This code is written very defensively so that incompatibilities don't affect us much. Given that glibc really has a duty to maintain compat between differently compiled programs and their system nscd they can't break API and thus it should be safe for us to implement an alternative, minimalistic client. Ideally this kind of explicit, global cache flushing would not be necessary. However nscd currently has no cache coherency protocol, hence we can't really implement this better. The only concept it knows is a TTL for positive hosts lookups. Hoewver for negative lookups or any of the other tables nothing is available.
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 9863ecc8f0..ea049a6fba 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -94,6 +94,17 @@ tests += [
libblkid],
'', 'manual'],
+ [['src/test/test-nscd-flush.c'],
+ [libcore,
+ libshared],
+ [threads,
+ librt,
+ libseccomp,
+ libselinux,
+ libmount,
+ libblkid],
+ '', 'manual'],
+
[['src/test/test-loopback.c'],
[libcore,
libshared],