summaryrefslogtreecommitdiff
path: root/src/timesync/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-05-16 16:11:04 +0200
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-05-19 10:25:12 +0900
commit54e6c7624f86330036a5bffd20a9400827d90c58 (patch)
treebe22cbb47d4745e6ebe9ff3057469b477fd989e5 /src/timesync/meson.build
parent94e41ec098e7389ced936ebee2c810928bb268e4 (diff)
downloadsystemd-54e6c7624f86330036a5bffd20a9400827d90c58.tar.gz
meson: use jinja2 in src/timesync/
Diffstat (limited to 'src/timesync/meson.build')
-rw-r--r--src/timesync/meson.build17
1 files changed, 9 insertions, 8 deletions
diff --git a/src/timesync/meson.build b/src/timesync/meson.build
index 30d2a0caee..ec80b16e82 100644
--- a/src/timesync/meson.build
+++ b/src/timesync/meson.build
@@ -34,15 +34,16 @@ libtimesyncd_core = static_library(
include_directories : includes,
link_with : [timesyncd_link_with])
+custom_target(
+ 'timesyncd.conf',
+ input : 'timesyncd.conf.in',
+ output : 'timesyncd.conf',
+ command : [meson_render_jinja2, config_h, '@INPUT@'],
+ capture : true,
+ install : conf.get('ENABLE_TIMESYNCD') == 1 and install_sysconfdir_samples,
+ install_dir : pkgsysconfdir)
+
if conf.get('ENABLE_TIMESYNCD') == 1
- timesyncd_conf = configure_file(
- input : 'timesyncd.conf.in',
- output : 'timesyncd.conf',
- configuration : substs)
- if install_sysconfdir_samples
- install_data(timesyncd_conf,
- install_dir : pkgsysconfdir)
- endif
install_data('org.freedesktop.timesync1.conf',
install_dir : dbuspolicydir)
install_data('org.freedesktop.timesync1.service',