summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-04-02 17:01:34 +0200
committerLennart Poettering <lennart@poettering.net>2020-04-02 17:04:59 +0200
commitaade0c3b6e6f7a6d860cbcaf48a1d6dc02f4f460 (patch)
tree1f8007ae665b2dc76fcf9e0d744b5c2a330a06e4 /units/meson.build
parent0fc659eea9aef031d1aa6cf729f3927abcfcb922 (diff)
downloadsystemd-aade0c3b6e6f7a6d860cbcaf48a1d6dc02f4f460.tar.gz
Revert "units: make systemd-repart.service installable"
This reverts commit 7e1ed1f3b29162df25064b33dc55ac8cf432bb0b. systemd-repart is not a user service that should be something people enable/disable, instead it should just work if there's configuration for it. It's like systemd-tmpfiles, systemd-sysusers, systemd-load-modules, systemd-binfmt, systemd-systemd-sysctl which are NOPs if they have no configuration, and thus don't hurt, but cannot be disabled since they are too deep part of the OS. This doesn't mean people couldn't disable the service if they really want to, there's after all "systemctl mask" and build-time disabling, but those are OS developer facing instead of admin facing, that's how it should be. Note that systemd-repart is in particular an initrd service, and so far enable/disable state of those is not managed anyway via "systemctl enable/disable" but more what dracut decides to package up and what not.
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/units/meson.build b/units/meson.build
index 8ec9eb94e4..ba3abc29ea 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -226,7 +226,8 @@ in_units = [
'multi-user.target.wants/'],
['systemd-vconsole-setup.service', 'ENABLE_VCONSOLE'],
['systemd-volatile-root.service', ''],
- ['systemd-repart.service', 'ENABLE_REPART'],
+ ['systemd-repart.service', 'ENABLE_REPART',
+ 'sysinit.target.wants/ initrd-root-fs.target.wants/'],
['user-runtime-dir@.service', ''],
['user@.service', ''],
]