summaryrefslogtreecommitdiff
path: root/docs/gudev/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/gudev/Makefile.am')
-rw-r--r--docs/gudev/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/docs/gudev/Makefile.am b/docs/gudev/Makefile.am
index 586dd8d190..26c8652b0a 100644
--- a/docs/gudev/Makefile.am
+++ b/docs/gudev/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in
# We require automake 1.10 at least.
-AUTOMAKE_OPTIONS = 1.10
+AUTOMAKE_OPTIONS = 1.10 color-tests
# This is a blank Makefile.am for using gtk-doc.
# Copy this to your project's API docs directory and modify the variables to
@@ -43,7 +43,7 @@ MKHTML_OPTIONS=--path=$(abs_srcdir) --path=$(abs_builddir)
# Extra options to supply to gtkdoc-fixref. Not normally needed.
# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
-FIXXREF_OPTIONS=
+FIXXREF_OPTIONS=>/dev/null 2>&1
# Used for dependencies. The docs will be rebuilt if any of these change.
# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
@@ -72,6 +72,14 @@ content_files = version.xml
# e.g. expand_content_files=running.sgml
expand_content_files=
+# Hack, hack. You silly gtk-doc, you must not add CFLAGS multiple
+# times when calling gcc; it surely can not work with options that must
+# be listed only once.
+# Kill CFLAGS here because gtk-doc thinks adding CFLAGS to CC _and_ also
+# adding CFLAGS itself again would work.
+override CFLAGS=
+override LDFLAGS=
+
# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
# Only needed if you are using gtkdoc-scangobj to dynamically query widget
# signals and properties.