summaryrefslogtreecommitdiff
path: root/hwdb.d/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hwdb.d/meson.build')
-rw-r--r--hwdb.d/meson.build62
1 files changed, 30 insertions, 32 deletions
diff --git a/hwdb.d/meson.build b/hwdb.d/meson.build
index fc72ebb2bd..21079d077a 100644
--- a/hwdb.d/meson.build
+++ b/hwdb.d/meson.build
@@ -3,39 +3,37 @@
# Those files right now are not supported by the grammar. Also,
# they are very long but quite repetitive and the parser is not very fast.
# So we don't "test" them.
-hwdb_files_notest = files('''
- README
- 20-dmi-id.hwdb
- 20-pci-vendor-model.hwdb
- 20-pci-classes.hwdb
- 20-usb-vendor-model.hwdb
- 20-usb-classes.hwdb
- 20-sdio-vendor-model.hwdb
- 20-sdio-classes.hwdb
- 20-bluetooth-vendor-product.hwdb
- 20-acpi-vendor.hwdb
- 20-OUI.hwdb
- 20-net-ifname.hwdb
- 20-vmbus-class.hwdb
-'''.split())
+hwdb_files_notest = files(
+ 'README',
+ '20-dmi-id.hwdb',
+ '20-pci-vendor-model.hwdb',
+ '20-pci-classes.hwdb',
+ '20-usb-vendor-model.hwdb',
+ '20-usb-classes.hwdb',
+ '20-sdio-vendor-model.hwdb',
+ '20-sdio-classes.hwdb',
+ '20-bluetooth-vendor-product.hwdb',
+ '20-acpi-vendor.hwdb',
+ '20-OUI.hwdb',
+ '20-net-ifname.hwdb',
+ '20-vmbus-class.hwdb')
-hwdb_files_test = files('''
- 60-autosuspend.hwdb
- 60-autosuspend-fingerprint-reader.hwdb
- 60-evdev.hwdb
- 60-input-id.hwdb
- 60-keyboard.hwdb
- 60-seat.hwdb
- 60-sensor.hwdb
- 70-analyzers.hwdb
- 70-cameras.hwdb
- 70-joystick.hwdb
- 70-mouse.hwdb
- 70-pda.hwdb
- 70-pointingstick.hwdb
- 70-touchpad.hwdb
- 80-ieee1394-unit-function.hwdb
-'''.split())
+hwdb_files_test = files(
+ '60-autosuspend.hwdb',
+ '60-autosuspend-fingerprint-reader.hwdb',
+ '60-evdev.hwdb',
+ '60-input-id.hwdb',
+ '60-keyboard.hwdb',
+ '60-seat.hwdb',
+ '60-sensor.hwdb',
+ '70-analyzers.hwdb',
+ '70-cameras.hwdb',
+ '70-joystick.hwdb',
+ '70-mouse.hwdb',
+ '70-pda.hwdb',
+ '70-pointingstick.hwdb',
+ '70-touchpad.hwdb',
+ '80-ieee1394-unit-function.hwdb')
if conf.get('ENABLE_HWDB') == 1
auto_suspend_rules = custom_target(