summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/man/meson.build b/man/meson.build
index b21631b873..ff36d26cb4 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -26,10 +26,12 @@ custom_man_xsl = files('custom-man.xsl')
custom_html_xsl = files('custom-html.xsl')
xslt_cmd = [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags
-custom_entities_ent = configure_file(
+custom_entities_ent = custom_target(
+ 'custom-entities.ent',
input : 'custom-entities.ent.in',
output : 'custom-entities.ent',
- configuration : conf)
+ command : [meson_render_jinja2, config_h, '@INPUT@'],
+ capture : true)
man_pages = []
html_pages = []
@@ -60,7 +62,7 @@ foreach tuple : xsltproc.found() ? manpages : []
input : xml,
output : [man] + manaliases,
command : xslt_cmd + [custom_man_xsl, '@INPUT@'],
- depend_files : custom_entities_ent,
+ depends : custom_entities_ent,
install : want_man,
install_dir : mandirn)
man_pages += p1
@@ -85,8 +87,7 @@ foreach tuple : xsltproc.found() ? manpages : []
input : xml,
output : html,
command : xslt_cmd + [custom_html_xsl, '@INPUT@'],
- depend_files : custom_entities_ent,
- depends : p2,
+ depends : [custom_entities_ent, p2],
install : want_html,
install_dir : join_paths(docdir, 'html'))
html_pages += p3
@@ -163,8 +164,7 @@ foreach tuple : xsltproc.found() ? [['systemd.directives', '7', systemd_directiv
input : xml,
output : html,
command : xslt_cmd + [custom_html_xsl, '@INPUT@'],
- depend_files : custom_entities_ent,
- depends : p2,
+ depends : [custom_entities_ent, p2],
install : want_html and have_lxml,
install_dir : join_paths(docdir, 'html'))
html_pages += p3