summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build40
1 files changed, 25 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index dba721208b..ab2404c3c4 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-# SPDX-License-Identifier: LGPL-2.1+
+# SPDX-License-Identifier: LGPL-2.1-or-later
project('systemd', 'c',
version : '247',
@@ -126,6 +126,7 @@ if rootlibdir == ''
rootlibdir = join_paths(rootprefixdir, libdir.split('/')[-1])
endif
+install_sysconfdir = get_option('install-sysconfdir')
# Dirs of external packages
pkgconfigdatadir = get_option('pkgconfigdatadir') == '' ? join_paths(datadir, 'pkgconfig') : get_option('pkgconfigdatadir')
pkgconfiglibdir = get_option('pkgconfiglibdir') == '' ? join_paths(libdir, 'pkgconfig') : get_option('pkgconfiglibdir')
@@ -1073,6 +1074,7 @@ else
libcurl = []
endif
conf.set10('HAVE_LIBCURL', have)
+conf.set10('CURL_NO_OLDIES', get_option('mode') == 'developer')
want_libidn = get_option('libidn')
want_libidn2 = get_option('libidn2')
@@ -1418,7 +1420,7 @@ if have == 'auto'
else
have = have == 'true'
if have and get_option('mode') != 'developer'
- error('oomd is not available in release mode (yet)')
+ warning('oomd is not ready for release mode (yet)')
endif
endif
conf.set10('ENABLE_OOMD', have)
@@ -1593,6 +1595,7 @@ generate_gperfs = find_program('tools/generate-gperfs.py')
subdir('po')
subdir('catalog')
+subdir('src/libudev')
subdir('src/systemd')
subdir('src/basic')
subdir('src/libsystemd')
@@ -1672,7 +1675,6 @@ update_dbus_docs_py = find_program('tools/update-dbus-docs.py')
# usually, but not always, installed in /bin.
public_programs = []
-subdir('src/libudev')
subdir('src/shared')
subdir('src/core')
subdir('src/shutdown')
@@ -2776,8 +2778,10 @@ if conf.get('ENABLE_BINFMT') == 1
meson.add_install_script('sh', '-c',
mkdir_p.format(binfmtdir))
- meson.add_install_script('sh', '-c',
- mkdir_p.format(join_paths(sysconfdir, 'binfmt.d')))
+ if install_sysconfdir
+ meson.add_install_script('sh', '-c',
+ mkdir_p.format(join_paths(sysconfdir, 'binfmt.d')))
+ endif
endif
if conf.get('ENABLE_REPART') == 1
@@ -2891,8 +2895,10 @@ executable(
install : true,
install_dir : rootlibexecdir)
-install_data('src/sleep/sleep.conf',
- install_dir : pkgsysconfdir)
+if install_sysconfdir
+ install_data('src/sleep/sleep.conf',
+ install_dir : pkgsysconfdir)
+endif
public_programs += executable(
'systemd-sysctl',
@@ -3242,8 +3248,10 @@ if conf.get('HAVE_KMOD') == 1
meson.add_install_script('sh', '-c',
mkdir_p.format(modulesloaddir))
- meson.add_install_script('sh', '-c',
- mkdir_p.format(join_paths(sysconfdir, 'modules-load.d')))
+ if install_sysconfdir
+ meson.add_install_script('sh', '-c',
+ mkdir_p.format(join_paths(sysconfdir, 'modules-load.d')))
+ endif
endif
public_programs += executable(
@@ -3430,7 +3438,7 @@ endif
fuzzer_exes = []
-if get_option('tests') != 'false'
+if fuzz_tests or fuzzer_build
foreach tuple : fuzzers
sources = tuple[0]
link_with = tuple[1].length() > 0 ? tuple[1] : [libshared]
@@ -3488,8 +3496,10 @@ subdir('docs/var-log')
install_subdir('factory/etc',
install_dir : factorydir)
-install_data('xorg/50-systemd-user.sh',
- install_dir : xinitrcdir)
+if install_sysconfdir
+ install_data('xorg/50-systemd-user.sh',
+ install_dir : xinitrcdir)
+endif
install_data('modprobe.d/systemd.conf',
install_dir : modprobedir)
install_data('LICENSE.GPL2',
@@ -3550,7 +3560,7 @@ foreach tuple : sanitizers
if name != prev
if want_tests == 'false'
message('Not compiling @0@ because tests is set to false'.format(name))
- elif slow_tests or fuzz_tests
+ elif fuzz_tests
exe = custom_target(
name,
output : name,
@@ -3560,12 +3570,12 @@ foreach tuple : sanitizers
'@OUTPUT@'],
build_by_default : true)
else
- message('Not compiling @0@ because slow-tests/fuzz-tests is set to false'.format(name))
+ message('Not compiling @0@ because fuzz-tests is set to false'.format(name))
endif
endif
prev = name
- if want_tests != 'false' and (slow_tests or fuzz_tests)
+ if fuzz_tests
test('@0@:@1@:@2@'.format(b, c, sanitizer),
env,
env : ['UBSAN_OPTIONS=print_stacktrace=1:print_summary=1:halt_on_error=1'],