summaryrefslogtreecommitdiff
path: root/tmpfiles.d/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tmpfiles.d/meson.build')
-rw-r--r--tmpfiles.d/meson.build34
1 files changed, 21 insertions, 13 deletions
diff --git a/tmpfiles.d/meson.build b/tmpfiles.d/meson.build
index da87ea5056..7a48389be4 100644
--- a/tmpfiles.d/meson.build
+++ b/tmpfiles.d/meson.build
@@ -4,7 +4,6 @@ tmpfiles = [['home.conf', ''],
['journal-nocow.conf', ''],
['systemd-nologin.conf', ''],
['systemd-nspawn.conf', ''],
- ['systemd-remote.conf', 'ENABLE_REMOTE'],
['tmp.conf', ''],
['x11.conf', ''],
['legacy.conf', 'HAVE_SYSV_COMPAT'],
@@ -21,19 +20,28 @@ foreach pair : tmpfiles
endif
endforeach
-m4_files = ['etc.conf',
- 'systemd.conf',
- 'var.conf']
+m4_files = [['etc.conf', ''],
+ ['systemd.conf', ''],
+ ['systemd-remote.conf', 'ENABLE_REMOTE'],
+ ['var.conf', ''],
+ ]
-foreach file : m4_files
- custom_target(
- 'tmpfiles.d/' + file,
- input : file + '.m4',
- output: file,
- command : [m4, '-P'] + m4_defines + ['@INPUT@'],
- capture : true,
- install : enable_tmpfiles,
- install_dir : tmpfilesdir)
+foreach pair : m4_files
+ if not enable_tmpfiles
+ # do nothing
+ elif pair[1] == '' or conf.get(pair[1], false)
+ custom_target(
+ 'tmpfiles.d/' + pair[0],
+ input : pair[0] + '.m4',
+ output: pair[0],
+ command : [m4, '-P'] + m4_defines + ['@INPUT@'],
+ capture : true,
+ install : true,
+ install_dir : tmpfilesdir)
+ else
+ message('Not installing tmpfiles.d/@0@.m4 because @1@ is @2@'
+ .format(pair[0], pair[1], conf.get(pair[1], 0)))
+ endif
endforeach
if enable_tmpfiles