summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/units/meson.build b/units/meson.build
index e249539dc8..ba60eb7fc1 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -326,9 +326,11 @@ install_data('user-.slice.d/10-defaults.conf',
############################################################
-meson.add_install_script(meson_make_symlink,
- join_paths(pkgsysconfdir, 'user'),
- join_paths(sysconfdir, 'xdg/systemd/user'))
+if install_sysconfdir
+ meson.add_install_script(meson_make_symlink,
+ join_paths(pkgsysconfdir, 'user'),
+ join_paths(sysconfdir, 'xdg/systemd/user'))
+endif
meson.add_install_script(meson_make_symlink,
join_paths(dbussystemservicedir, 'org.freedesktop.systemd1.service'),
join_paths(dbussessionservicedir, 'org.freedesktop.systemd1.service'))