summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2019-10-29 18:45:43 -0700
committerGuy Harris <guy@alum.mit.edu>2019-10-29 18:45:43 -0700
commitc05087101abe59f1c7adc98644cd97a05fdc1279 (patch)
tree97fbf6f46eb10c45ffd638fa624f5ec66a65e766 /CMakeLists.txt
parentc58f88896c126a31b7c497d085a34b26126439fd (diff)
downloadtcpdump-c05087101abe59f1c7adc98644cd97a05fdc1279.tar.gz
Use PCAP_ROOT to tell CMake where to find Npcap or WinPcap.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5768db5e..3f9dd836 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,14 @@
cmake_minimum_required(VERSION 2.8.6)
+#
+# We want find_path() and find_library() to honor {packagename}_ROOT,
+# as that appears to be the standard way to say "hey, look here for
+# this package" from the command line.
+#
+if(POLICY CMP0074)
+ cmake_policy(SET CMP0074 NEW)
+endif()
+
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules)
project(tcpdump)