summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2009-11-10 19:35:00 +0000
committerWill Thompson <will.thompson@collabora.co.uk>2009-11-20 18:42:30 +0000
commitec0baa4f19d9963cbcfb7fcbdb74b947115fad45 (patch)
treed34ef4d33511105957169f6270a4ced9e24d70de /src/Makefile.am
parent290f7337b7e145f51a6eb61a7318862e0f9055ed (diff)
downloadtelepathy-gabble-ec0baa4f19d9963cbcfb7fcbdb74b947115fad45.tar.gz
Link against GModule when plugins are enabled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d2b06e34c..b886994ee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -168,12 +168,12 @@ noinst_LTLIBRARIES = libgabble-convenience.la
AM_CFLAGS = $(ERROR_CFLAGS) -I$(top_srcdir) -I$(top_builddir) \
@DBUS_CFLAGS@ @GLIB_CFLAGS@ @WOCKY_CFLAGS@ \
@HANDLE_LEAK_DEBUG_CFLAGS@ @TP_GLIB_CFLAGS@ \
- @SOUP_CFLAGS@ @UUID_CFLAGS@ \
+ @SOUP_CFLAGS@ @UUID_CFLAGS@ @GMODULE_CFLAGS@ \
-I $(top_srcdir)/lib -I $(top_builddir)/lib \
-DG_LOG_DOMAIN=\"gabble\"
ALL_LIBS = @DBUS_LIBS@ @GLIB_LIBS@ @WOCKY_LIBS@ @TP_GLIB_LIBS@ \
- @SOUP_LIBS@ @UUID_LIBS@
+ @SOUP_LIBS@ @UUID_LIBS@ @GMODULE_LIBS@
# build gibber first
all: gibber