summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 870a4e202..b231896b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,9 +14,13 @@ check-local::
egrep -A 5 '[F]IXME|[T]ODO|[X]XX' $(srcdir)/telepathy-glib/*.[ch] \
> FIXME.out || true
+# Use git log --stat if it works, else plain git log
dist-hook:
chmod u+w ${distdir}/ChangeLog
- if test -d _darcs; then darcs changes >${distdir}/ChangeLog; fi
+ if test -d ${top_srcdir}/.git; then \
+ git log --stat > ${distdir}/ChangeLog || \
+ git log > ${distdir}/ChangeLog; \
+ fi
maintainer-upload-docs:
rsync -rtvzPp --chmod=Dg+s,ug+rwX,o=rX docs/reference/html/ \