summaryrefslogtreecommitdiff
path: root/examples/client/dbus-tubes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/client/dbus-tubes/Makefile.am')
-rw-r--r--examples/client/dbus-tubes/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/client/dbus-tubes/Makefile.am b/examples/client/dbus-tubes/Makefile.am
new file mode 100644
index 000000000..90411ff32
--- /dev/null
+++ b/examples/client/dbus-tubes/Makefile.am
@@ -0,0 +1,23 @@
+noinst_PROGRAMS = \
+ offerer \
+ accepter \
+ $(NULL)
+
+offerer_SOURCES = offerer.c constants.h
+accepter_SOURCES = accepter.c constants.h
+
+# In an external project you'd use $(TP_GLIB_LIBS) (obtained from
+# pkg-config via autoconf) instead of the .la path
+LDADD = \
+ $(top_builddir)/telepathy-glib/libtelepathy-glib.la \
+ @DBUS_LIBS@ \
+ @GLIB_LIBS@
+
+AM_CFLAGS = \
+ $(ERROR_CFLAGS) \
+ @DBUS_CFLAGS@ \
+ @GLIB_CFLAGS@ \
+ @TP_GLIB_CFLAGS@
+AM_LDFLAGS = \
+ $(ERROR_LDFLAGS) \
+ $(NULL)