summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2009-07-01 18:41:40 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2009-07-01 18:43:31 +0100
commitb870865538ff4e1485b96fb5f10afd4f6843950c (patch)
tree26916bbc38966e682a6eef4be481ee4e16446c90 /configure.ac
parentd4e4b4c2e0b3653f7a13ab6cf6557f6b3908cc9d (diff)
downloadtelepathy-mission-control-b870865538ff4e1485b96fb5f10afd4f6843950c.tar.gz
fd.o #22332: make GConf only a weak dependency
* Make mc-tool not depend on GConf (there's no reason for it to do so) * Make GConf optional, and only build mc-account-convert if we do have it
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9392f1a5..81a829c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,9 @@ AC_SUBST(TELEPATHY_LIBS)
AC_SUBST(TELEPATHY_CFLAGS)
GCONF_REQUIRED_VERSION=2.0.0
-PKG_CHECK_MODULES(GCONF, gconf-2.0 >= $GCONF_REQUIRED_VERSION)
+PKG_CHECK_MODULES(GCONF, gconf-2.0 >= $GCONF_REQUIRED_VERSION,
+ [HAVE_GCONF=yes], [HAVE_GCONF=no])
+AM_CONDITIONAL(HAVE_GCONF, [test x$HAVE_GCONF = xyes])
AC_SUBST(GCONF_CFLAGS)
AC_SUBST(GCONF_LIBS)