summaryrefslogtreecommitdiff
path: root/tests/twisted/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/twisted/Makefile.am')
-rw-r--r--tests/twisted/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/twisted/Makefile.am b/tests/twisted/Makefile.am
index bc3dc09d..5832e53e 100644
--- a/tests/twisted/Makefile.am
+++ b/tests/twisted/Makefile.am
@@ -79,6 +79,7 @@ endif
# account-storage/*.py need their own instances.
TWISTED_SPECIAL_BUILD_TESTS = \
account-manager/auto-away.py \
+ account-manager/connectivity.py \
account-manager/hidden.py \
account-storage/default-keyring-storage.py \
account-storage/diverted-storage.py
@@ -103,9 +104,20 @@ else
HAVE_MCE_PYBOOL = False
endif
+if HAVE_NM
+HAVE_CONNECTIVITY_PYBOOL = True
+else
+if HAVE_CONNMAN
+HAVE_CONNECTIVITY_PYBOOL = True
+else
+HAVE_CONNECTIVITY_PYBOOL = False
+endif
+endif
+
config.py: Makefile
$(AM_V_GEN) { \
echo "HAVE_MCE = $(HAVE_MCE_PYBOOL)"; \
+ echo "HAVE_CONNECTIVITY = $(HAVE_CONNECTIVITY_PYBOOL)"; \
} > $@
BUILT_SOURCES = config.py