summaryrefslogtreecommitdiff
path: root/lib/lua/Makefile.am
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2014-04-05 00:45:42 +0200
committerRoger Meier <roger@apache.org>2014-04-05 00:50:35 +0200
commit6cf0ffcec969e4a983171a5f411506b2ed0fd2c1 (patch)
treef618a140d60a6d99af32225e260b7b5cb28b6cd1 /lib/lua/Makefile.am
parentbdbf428365144dc8586276d42c071b44c389e4ff (diff)
downloadthrift-6cf0ffcec969e4a983171a5f411506b2ed0fd2c1.tar.gz
THRIFT-1681: Add Lua Support Patch: Dave Watson
Github Pull Request: This closes #92
Diffstat (limited to 'lib/lua/Makefile.am')
-rw-r--r--lib/lua/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/lib/lua/Makefile.am b/lib/lua/Makefile.am
new file mode 100644
index 000000000..1c4296795
--- /dev/null
+++ b/lib/lua/Makefile.am
@@ -0,0 +1,58 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+SUBDIRS = .
+
+lib_LTLIBRARIES = libluasocket.la \
+ libluabpack.la \
+ libluabitwise.la \
+ liblualongnumber.la
+
+libluasocket_la_SOURCES = src/luasocket.c \
+ src/usocket.c
+
+libluasocket_la_CPPFLAGS = $(AM_CPPFLAGS) -I/usr/include/lua5.2 -DLUA_COMPAT_MODULE
+libluasocket_la_LDFLAGS = $(AM_LDFLAGS) -llua5.2 -lm
+
+libluabpack_la_SOURCES = src/luabpack.c
+
+libluabpack_la_CPPFLAGS = $(AM_CPPFLAGS) -I/usr/include/lua5.2 -DLUA_COMPAT_MODULE
+libluabpack_la_LDFLAGS = $(AM_LDFLAGS) -llua5.2 -lm
+libluabpack_la_LIBADD = liblualongnumber.la
+
+libluabitwise_la_SOURCES = src/luabitwise.c
+
+libluabitwise_la_CPPFLAGS = $(AM_CPPFLAGS) -I/usr/include/lua5.2 -DLUA_COMPAT_MODULE
+libluabitwise_la_LDFLAGS = $(AM_LDFLAGS) -llua5.2 -lm
+
+liblualongnumber_la_SOURCES = src/lualongnumber.c \
+ src/longnumberutils.c
+
+liblualongnumber_la_CPPFLAGS = $(AM_CPPFLAGS) -I/usr/include/lua5.2 -DLUA_COMPAT_MODULE
+liblualongnumber_la_LDFLAGS = $(AM_LDFLAGS) -llua5.2 -lm
+
+EXTRA_DIST = TBinaryProtocol.lua \
+ TBufferedTransport.lua \
+ TFramedTransport.lua \
+ Thrift.lua \
+ TMemoryBuffer.lua \
+ TProtocol.lua \
+ TServer.lua \
+ TSocket.lua \
+ TTransport.lua \ No newline at end of file