summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44f65afbf..f3005f56e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,4 +100,11 @@ if(BUILD_PYTHON)
endif()
endif()
+if(BUILD_HASKELL)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/hs)
+ if(BUILD_TESTING)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/hs)
+ endif()
+endif()
+
PRINT_CONFIG_SUMMARY()