summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 38dd8c9d6..ed58265ac 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,15 @@
ACLOCAL_AMFLAGS = -I ./aclocal
+if WITH_PLUGIN
+# To enable bootstrap, build order is lib/cpp -> compiler -> others
+SUBDIRS = lib/cpp compiler/cpp lib
+if WITH_TESTS
+SUBDIRS += lib/cpp/test
+endif
+else
SUBDIRS = compiler/cpp lib
+endif
if WITH_TESTS
SUBDIRS += test