summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0a9e43180..bbe6f8034 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,10 +37,18 @@ dist-hook:
print-version:
@echo $(VERSION)
+.PHONY: precross cross cross2
+precross-%: all
+ $(MAKE) -C $* precross
+precross: all precross-test precross-lib
-cross: check
+cross: precross
sh test/test.sh
+# TODO: generate --server and --client switches from "--with(out)-..." build flags
+cross2: precross
+ python test/test.py -s
+
codespell_skip_files = \
*.jar \
*.class \