diff options
author | Stefano Babic <sbabic@denx.de> | 2017-04-05 17:46:41 +0200 |
---|---|---|
committer | Simon Glass <sjg@chromium.org> | 2017-04-13 14:44:49 -0600 |
commit | b48bfc74ee410b1e6681c620633ffef32aafaba0 (patch) | |
tree | 51cd88bdee091c7b2b3139a5f76b6593ae716b36 | |
parent | 5a8a8045a928702d9b3fb6f73a4e9717040e09a9 (diff) | |
download | u-boot-b48bfc74ee410b1e6681c620633ffef32aafaba0.tar.gz |
tools: allow to override python
Not force to use python from PATH. Issue was noted when building with
Yocto, because python from the distro is always taken instead of
python-native built during Yocto process.
Signed-off-by: Stefano Babic <sbabic@denx.de>
CC: Simon Glass <sjg@chromium.org>
Reviewed-by: Simon Glass <sjg@chromium.org>
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | tools/Makefile | 2 |
2 files changed, 2 insertions, 2 deletions
@@ -348,7 +348,7 @@ OBJCOPY = $(CROSS_COMPILE)objcopy OBJDUMP = $(CROSS_COMPILE)objdump AWK = awk PERL = perl -PYTHON = python +PYTHON ?= python DTC = dtc CHECK = sparse diff --git a/tools/Makefile b/tools/Makefile index fa1b85bdae..2fc4a583d4 100644 --- a/tools/Makefile +++ b/tools/Makefile @@ -120,7 +120,7 @@ _libfdt.so-sharedobjs += $(LIBFDT_OBJS) libfdt: tools/_libfdt.so: $(patsubst %.o,%.c,$(LIBFDT_OBJS)) tools/libfdt_wrap.c - LDFLAGS="$(HOSTLDFLAGS)" CFLAGS= python $(srctree)/lib/libfdt/setup.py \ + LDFLAGS="$(HOSTLDFLAGS)" CFLAGS= ${PYTHON} $(srctree)/lib/libfdt/setup.py \ "$(_hostc_flags)" $^ mv _libfdt.so $@ |