diff options
author | Tom Rini <trini@konsulko.com> | 2019-04-11 14:29:22 -0400 |
---|---|---|
committer | Tom Rini <trini@konsulko.com> | 2019-04-11 14:29:22 -0400 |
commit | f95fdf237d8de9bf4dac4e4449015692c2283ac4 (patch) | |
tree | 385fc22a0f83526b1d5a900bbae6a5895af8ddbe /Makefile | |
parent | 48ff1bc4f0a97c3291d0c87c2717fc1d79da5ef5 (diff) | |
parent | c8630bb09674e2b8496753929ac4d0a610583f1e (diff) | |
download | u-boot-f95fdf237d8de9bf4dac4e4449015692c2283ac4.tar.gz |
Merge branch 'master' of git://git.denx.de/u-boot-sh
- Various rmobile fixes
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 16 |
1 files changed, 15 insertions, 1 deletions
@@ -1020,6 +1020,20 @@ quiet_cmd_copy = COPY $@ ifeq ($(CONFIG_MULTI_DTB_FIT),y) +ifeq ($(CONFIG_MULTI_DTB_FIT_LZO),y) +FINAL_DTB_CONTAINER = fit-dtb.blob.lzo +else ifeq ($(CONFIG_MULTI_DTB_FIT_GZIP),y) +FINAL_DTB_CONTAINER = fit-dtb.blob.gz +else +FINAL_DTB_CONTAINER = fit-dtb.blob +endif + +fit-dtb.blob.gz: fit-dtb.blob + @gzip -kf9 $< > $@ + +fit-dtb.blob.lzo: fit-dtb.blob + @lzop -f9 $< > $@ + fit-dtb.blob: dts/dt.dtb FORCE $(call if_changed,mkimage) @@ -1027,7 +1041,7 @@ MKIMAGEFLAGS_fit-dtb.blob = -f auto -A $(ARCH) -T firmware -C none -O u-boot \ -a 0 -e 0 -E \ $(patsubst %,-b arch/$(ARCH)/dts/%.dtb,$(subst ",,$(CONFIG_OF_LIST))) -d /dev/null -u-boot-fit-dtb.bin: u-boot-nodtb.bin fit-dtb.blob +u-boot-fit-dtb.bin: u-boot-nodtb.bin $(FINAL_DTB_CONTAINER) $(call if_changed,cat) u-boot.bin: u-boot-fit-dtb.bin FORCE |