summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--arch/sh/cpu/sh4/config.mk2
-rw-r--r--arch/sh/cpu/u-boot.lds1
-rw-r--r--arch/sh/dts/sh7751-r2dplus.dts3
-rw-r--r--configs/r2dplus_defconfig1
4 files changed, 5 insertions, 2 deletions
diff --git a/arch/sh/cpu/sh4/config.mk b/arch/sh/cpu/sh4/config.mk
index d62d285e60..23fec66492 100644
--- a/arch/sh/cpu/sh4/config.mk
+++ b/arch/sh/cpu/sh4/config.mk
@@ -6,4 +6,4 @@
# (C) Copyright 2007
# Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
#
-PLATFORM_CPPFLAGS += -m4-nofpu
+PLATFORM_CPPFLAGS += $(call cc-option,-m4-nofpu,-m4)
diff --git a/arch/sh/cpu/u-boot.lds b/arch/sh/cpu/u-boot.lds
index 47302da252..4cc97737f1 100644
--- a/arch/sh/cpu/u-boot.lds
+++ b/arch/sh/cpu/u-boot.lds
@@ -25,6 +25,7 @@ ENTRY(_start)
SECTIONS
{
+ . = CONFIG_SYS_TEXT_BASE;
reloc_dst = .;
PROVIDE (_ftext = .);
diff --git a/arch/sh/dts/sh7751-r2dplus.dts b/arch/sh/dts/sh7751-r2dplus.dts
index ecaf0772d8..efaeb33e36 100644
--- a/arch/sh/dts/sh7751-r2dplus.dts
+++ b/arch/sh/dts/sh7751-r2dplus.dts
@@ -21,6 +21,7 @@
#size-cells = <2>;
#interrupt-cells = <1>;
ranges = <0x01000000 0 0xfe240000 0 0xfe240000 0 0x00040000
- 0x02000000 0 0xfd000000 0 0xfd000000 0 0x01000000>;
+ 0x02000000 0 0xfd000000 0 0xfd000000 0 0x01000000
+ 0x42000000 0 0x0c000000 0 0x8c000000 0 0x04000000>;
};
};
diff --git a/configs/r2dplus_defconfig b/configs/r2dplus_defconfig
index b2334affc3..e10ac939c5 100644
--- a/configs/r2dplus_defconfig
+++ b/configs/r2dplus_defconfig
@@ -12,6 +12,7 @@ CONFIG_CMD_DM=y
CONFIG_CMD_IDE=y
CONFIG_CMD_PCI=y
# CONFIG_CMD_SETEXPR is not set
+CONFIG_CMD_DHCP=y
CONFIG_CMD_PING=y
CONFIG_CMD_CACHE=y
CONFIG_CMD_EXT2=y