| Commit message (Expand) | Author | Age | Files | Lines |
* | gpio: atmel_pio4: add support for sama7g5 pio4 version with 5 banks | Eugen Hristev | 2021-04-19 | 1 | -0/+22 |
* | gpio: Drop dm_gpio_set_dir() | Simon Glass | 2021-04-12 | 1 | -11/+0 |
* | x86: Probe device if needed in intel_gpio_xlate() | Simon Glass | 2021-03-27 | 1 | -1/+13 |
* | Merge tag 'v2021.04-rc4' into next | Tom Rini | 2021-03-15 | 1 | -3/+4 |
|\ |
|
| * | gpio: mpc8xxx: Support controller register physical address beyond 32-bit | Bin Meng | 2021-03-05 | 1 | -3/+4 |
* | | gpio: Add a way to read 3-way strapping pinsWIP/2021-03-03-gpio-improvements | Simon Glass | 2021-03-03 | 2 | -4/+90 |
* | | gpio: Define the log category in the uclass | Simon Glass | 2021-03-03 | 1 | -0/+2 |
* | | gpio: sandbox: Track whether a GPIO is driven | Simon Glass | 2021-03-03 | 1 | -6/+15 |
* | | gpio: x86: Drop the deprecated methods in intel_gpio | Simon Glass | 2021-03-03 | 1 | -34/+38 |
* | | gpio: Use an 'ops' variable everywhere | Simon Glass | 2021-03-03 | 1 | -11/+14 |
* | | gpio: Replace direction_input() and direction_output() | Simon Glass | 2021-03-03 | 1 | -9/+6 |
* | | dm: gpio: Add a way to update flags | Simon Glass | 2021-03-03 | 2 | -18/+60 |
* | | gpio: sandbox: Make sandbox_gpio_set_flags() set all flags | Simon Glass | 2021-03-03 | 1 | -9/+12 |
* | | gpio: sandbox: Fully separate pin value from output value | Simon Glass | 2021-03-03 | 1 | -4/+20 |
* | | gpio: sandbox: Use a separate flag for the value | Simon Glass | 2021-03-03 | 1 | -23/+24 |
* | | gpio: sandbox: Rename GPIO dir_flags to flags | Simon Glass | 2021-03-03 | 1 | -26/+34 |
* | | gpio: Rename dm_gpio_get_dir_flags() to dm_gpio_get_flags() | Simon Glass | 2021-03-03 | 1 | -1/+1 |
* | | dm: gpio: Rename get_dir_flags() method to get_flags() | Simon Glass | 2021-03-03 | 3 | -23/+23 |
* | | dm: gpio: Rename set_dir_flags() method to update_flags() | Simon Glass | 2021-03-03 | 3 | -14/+14 |
* | | gpio: Disable functions not used with of-platdata | Simon Glass | 2021-03-03 | 1 | -0/+2 |
|/ |
|
* | Merge branch '2021-02-02-drop-asm_global_data-when-unused' | Tom Rini | 2021-02-15 | 17 | -0/+17 |
|\ |
|
| * | common: Drop asm/global_data.h from common headerWIP/2021-02-02-drop-asm_global_data-when-unused | Simon Glass | 2021-02-02 | 17 | -0/+17 |
* | | gpio: mpc8xxx_gpio: Fix for litte endian | Biwen Li | 2021-02-08 | 1 | -39/+8 |
|/ |
|
* | gpio: Add support for DM GPIO for Kirkwood | Harm Berntsen | 2021-01-27 | 1 | -1/+1 |
* | Merge https://gitlab.denx.de/u-boot/custodians/u-boot-sunxiWIP/25Jan2021 | Tom Rini | 2021-01-25 | 1 | -0/+2 |
|\ |
|
| * | sunxi: gpio: introduce compatible for H616 | Jernej Skrabec | 2021-01-25 | 1 | -0/+2 |
* | | gpio: add GPIO controller driver for MediaTek MT7620 SoC | Weijie Gao | 2021-01-24 | 3 | -0/+155 |
|/ |
|
* | gpio: stm32-gpio: migrate trace to dev and log macro | Patrick Delaunay | 2021-01-13 | 1 | -1/+3 |
* | gpio: tca642x: fix input subcommand for gpio banks > 0 | Tomas Novotny | 2021-01-12 | 1 | -14/+35 |
* | dm: Rename U_BOOT_DRIVER_ALIAS to DM_DRIVER_ALIAS | Simon Glass | 2021-01-05 | 3 | -3/+3 |
* | dm: Rename DM_GET_DRIVER() to DM_DRIVER_GET() | Simon Glass | 2021-01-05 | 1 | -1/+1 |
* | dm: Rename U_BOOT_DEVICE() to U_BOOT_DRVINFO() | Simon Glass | 2021-01-05 | 2 | -3/+3 |
* | dm: core: Access device ofnode through functions | Simon Glass | 2021-01-05 | 2 | -3/+3 |
* | dm: core: Use dev_has_ofnode() instead of dev_of_valid() | Simon Glass | 2021-01-05 | 1 | -1/+1 |
* | x86: apl: Reduce size for TPL | Simon Glass | 2021-01-05 | 1 | -1/+3 |
* | dm: Use access methods for dev/uclass private data | Simon Glass | 2021-01-05 | 13 | -21/+25 |
* | gpio: Update for new sequence numbers | Simon Glass | 2020-12-18 | 5 | -5/+5 |
* | dm: Avoid accessing seq directly | Simon Glass | 2020-12-18 | 1 | -1/+1 |
* | dm: treewide: Rename ..._platdata variables to just ..._plat | Simon Glass | 2020-12-13 | 26 | -146/+146 |
* | dm: treewide: Rename ofdata_to_platdata() to of_to_plat() | Simon Glass | 2020-12-13 | 22 | -44/+44 |
* | dm: treewide: Rename dev_get_platdata() to dev_get_plat() | Simon Glass | 2020-12-13 | 26 | -109/+109 |
* | dm: treewide: Rename 'platdata' variables to just 'plat' | Simon Glass | 2020-12-13 | 29 | -117/+113 |
* | dm: treewide: Rename auto_alloc_size members to be shorter | Simon Glass | 2020-12-13 | 43 | -58/+58 |
* | dm: Drop uses of dev_set_of_offset() | Simon Glass | 2020-12-13 | 5 | -12/+6 |
* | dm: Remove uses of device_bind_offset() | Simon Glass | 2020-12-13 | 5 | -11/+11 |
* | dm: core: Rename device_bind_ofnode() to device_bind() | Simon Glass | 2020-12-13 | 1 | -2/+2 |
* | dm: core: Rename device_bind() to device_bind_offset() | Simon Glass | 2020-12-13 | 5 | -10/+11 |
* | gpio: Convert to use APIs which support live DT | Patrick Delaunay | 2020-12-01 | 1 | -3/+2 |
* | gpio: stm32: correct the bias management | Patrick Delaunay | 2020-11-25 | 1 | -14/+14 |
* | sunxi: gpio: introduce compatible string for V3 GPIO | Icenowy Zheng | 2020-11-17 | 1 | -0/+1 |