summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2016-10-13 22:25:56 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2016-10-25 11:13:10 +0200
commitfbc749bd4ec84673ace5b311ec468c75ab049e1f (patch)
treeae0ce1224adab2ff2f65144b1fc797258d24661b /configure.ac
parent64b9bfc1bc0abfed45ad07a8ebaef8a5f167f848 (diff)
downloadvala-fbc749bd4ec84673ace5b311ec468c75ab049e1f.tar.gz
build: Conditionally adjust VALAFLAGS in case of proper bootsrapped builds
This adds --hide-internal to VALAFLAGS to allow symbols to be marked 'internal' in Vala source files and not appear in the dynamic symbol table of libvala. The build system checks for minimum valac version to fullfill required support of needed VALAFLAGS. https://bugzilla.gnome.org/show_bug.cgi?id=771920
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f12d4efbc..540d4a2bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,16 @@ fi
AC_PATH_PROG(VALAC, valac, valac)
AC_SUBST(VALAC)
+VALAC_BOOTSTRAP_REQUIRED=0.25.1
+
+AS_IF([test "$VALAC" != valac], [FOUND_VALAC_VERION=`$VALAC --version | sed 's/Vala *//'`
+ AS_VERSION_COMPARE(["$VALAC_BOOTSTRAP_REQUIRED"], ["$FOUND_VALAC_VERION"],
+ [enable_boostrap=yes], [enable_boostrap=yes], [enable_boostrap=no])])
+
VALAFLAGS="$VALAFLAGS --disable-version-header"
+if test x$enable_boostrap = xyes; then
+ VALAFLAGS="$VALAFLAGS --hide-internal"
+fi
AC_SUBST(VALAFLAGS)
AC_SUBST(CFLAGS)