summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 82ed2f505..e816fb0a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,22 @@ DIST_SUBDIRS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = vala-1.0.pc
+dist-hook: gen-ChangeLog
+
+gen_start_date = 2009-02-25
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d .git; then \
+ $(top_srcdir)/gitlog-to-changelog \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
EXTRA_DIST = \
ChangeLog.pre-0-4 \
+ ChangeLog.pre-0-5-7 \
+ gitlog-to-changelog \
MAINTAINERS \
vala-1.0.pc.in \
$(NULL)