summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2011-01-04 12:50:41 +0100
committerAli Abdallah <aliov@xfce.org>2011-01-04 12:50:41 +0100
commitbda605a30808def8b66f144deae800eb9a985f59 (patch)
treec40db3a5e6469c0bcce7ac7f38dd1a7da93a3417 /common/Makefile.am
parent887bbe6922a6a8ebb894d75456ecffab6ce2c0d7 (diff)
downloadixfce4-power-manager-bda605a30808def8b66f144deae800eb9a985f59.tar.gz
HAL has been deprecated and unmaintained for a long time now, and isn't being
installed by newer distros any more, so it's time to get rid of the HAL brightness backend entirely, so drop it. Since there are still X.org drivers which do not support brightness setting through XRandR, add a xfpm-power-backlight-helper program which reads/writes brightness setting in /sys/class/backlight/, and use it as a fallback if XRandR brightness isn't available. Reading doesn't require any privileges, but for writing the helper needs to be run as root through pkexec, so add a default policy which allows running that without a password for the local foreground console. This was inspired from gnome-power-manager: http://git.gnome.org/browse/gnome-power-manager/commit/?id=4886023c and the helper code comes from gpm, with slight adaptions.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index fd5d98ca..e004a461 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -12,6 +12,7 @@ libxfpmcommon_la_SOURCES = \
libxfpmcommon_la_CFLAGS = \
-I$(top_srcdir) \
+ -DSBINDIR=\"$(sbindir)\" \
$(GTK_CFLAGS) \
$(GLIB_CFLAGS) \
$(LIBXFCE4UTIL_CFLAGS)
@@ -24,4 +25,4 @@ libxfpmcommon_la_CFLAGS += \
libxfpmcommon_la_LIBADD = \
$(top_builddir)/libhal/libxfpmhal.la
-endif \ No newline at end of file
+endif