summaryrefslogtreecommitdiff
path: root/plugins/windowmenu/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-02-26 14:08:20 +0100
committerNick Schermer <nick@xfce.org>2010-02-26 14:11:42 +0100
commit37a85de44a2c8016665838c4d27a51dffd29c4d4 (patch)
treea66fbf0b899f0dafabe08ce05d9d1e828cf6d676 /plugins/windowmenu/Makefile.am
parente633c0be32b2922a21449a576ad4babe2685121d (diff)
downloadxfce4-panel-37a85de44a2c8016665838c4d27a51dffd29c4d4.tar.gz
Update desktop files.
There is no path in the desktop files anymore, so drop the X-XFCE-Module-Path entry and rename the files to *.in, because we do not have to edit it during building.
Diffstat (limited to 'plugins/windowmenu/Makefile.am')
-rw-r--r--plugins/windowmenu/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/plugins/windowmenu/Makefile.am b/plugins/windowmenu/Makefile.am
index b2de2031..792c81a5 100644
--- a/plugins/windowmenu/Makefile.am
+++ b/plugins/windowmenu/Makefile.am
@@ -53,20 +53,16 @@ libwindowmenu_la_DEPENDENCIES = \
# .desktop file
#
desktopdir = $(datadir)/xfce4/panel-plugins
-desktop_in_in_files = windowmenu.desktop.in.in
-desktop_in_files = $(desktop_in_in_files:.desktop.in.in=.desktop.in)
-windowmenu.desktop.in: $(desktop_in_in_files)
- sed -e "s,\@plugindir\@,$(plugindir),g" < $< > $@
+desktop_in_files = windowmenu.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
EXTRA_DIST = \
windowmenu-dialog.glade \
- $(desktop_in_in_files)
+ $(desktop_in_files)
DISTCLEANFILES = \
- $(desktop_DATA) \
- $(desktop_in_files)
+ $(desktop_DATA)
if MAINTAINER_MODE
BUILT_SOURCES = \