summaryrefslogtreecommitdiff
path: root/xfconf/Makefile.am
diff options
context:
space:
mode:
authorBrian Tarricone <brian@tarricone.org>2007-11-06 05:52:22 +0000
committerBrian Tarricone <brian@tarricone.org>2007-11-06 05:52:22 +0000
commit3c1632488b0fe909eb14a3701eed1d2b2717ca37 (patch)
tree4c78c9614d8936e4a29483a19815f62f72cd05ed /xfconf/Makefile.am
parent759ae5768a878a87f208cb889974bee24e371d74 (diff)
downloadxfconf-3c1632488b0fe909eb14a3701eed1d2b2717ca37.tar.gz
add gnuc visibility stuff
(Old svn revision: 26769)
Diffstat (limited to 'xfconf/Makefile.am')
-rw-r--r--xfconf/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/xfconf/Makefile.am b/xfconf/Makefile.am
index 6f02a4b..ff5e239 100644
--- a/xfconf/Makefile.am
+++ b/xfconf/Makefile.am
@@ -16,6 +16,7 @@ libxfconf_0_la_SOURCES = \
xfconf.c
libxfconf_0_la_CFLAGS = \
+ -I$(top_srcdir) \
-I$(top_srcdir)/common \
-DLIBXFCONF_COMPILATION \
-DG_LOG_DOMAIN=\"xfconf\" \
@@ -38,6 +39,7 @@ libxfconf_0_la_LIBADD = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libxfconf-0.pc
+
if MAINTAINER_MODE
BUILT_SOURCES = \
@@ -48,5 +50,13 @@ xfconf-dbus-bindings.h: $(top_srcdir)/common/xfconf-dbus.xml Makefile
| sed -e 's/org_xfce_Xfconf_/xfconf_client_/g;' \
-e 's/_GUI_/_gui_/g;' > $@
+if HAVE_GNUC_VISIBILITY
+TESTS = abicheck.sh
+endif
+
endif
+
+EXTRA_DIST = \
+ abicheck.sh \
+ xfconf.symbols