summaryrefslogtreecommitdiff
path: root/xfconf/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-02-01 19:22:02 +0100
committerNick Schermer <nick@xfce.org>2010-02-01 19:39:03 +0100
commit4fe47563165e533d4c62c0e8a770ca9751567da0 (patch)
tree5155aac3700b3140b06cfd60c8ff5055855b9466 /xfconf/Makefile.am
parent96984ae53774f2a0d230ec5d81aded3cfc3ac01c (diff)
downloadxfconf-4fe47563165e533d4c62c0e8a770ca9751567da0.tar.gz
Silent the build.
Diffstat (limited to 'xfconf/Makefile.am')
-rw-r--r--xfconf/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/xfconf/Makefile.am b/xfconf/Makefile.am
index 3b0bf15..f636564 100644
--- a/xfconf/Makefile.am
+++ b/xfconf/Makefile.am
@@ -54,9 +54,9 @@ BUILT_SOURCES = \
xfconf-dbus-bindings.h
xfconf-dbus-bindings.h: $(top_srcdir)/common/xfconf-dbus.xml Makefile
- dbus-binding-tool --mode=glib-client $< > $(@).tmp
- sed -e 's/^\([[:space:]]\+GValue[[:space:]]\+[^=]\+\).*;$$/\1 = { 0, };/' <$(@).tmp >$@
- -rm -f $(@).tmp
+ $(AM_V_GEN) dbus-binding-tool --mode=glib-client $< > $(@).tmp \
+ && sed -e 's/^\([[:space:]]\+GValue[[:space:]]\+[^=]\+\).*;$$/\1 = { 0, };/' <$(@).tmp >$@ \
+ && rm -f $(@).tmp
# the above fixes a bug in dbus-binding-tool's output
# dbus-binding-tool doesn't initialise GValues to { 0, } properly